PDA

View Full Version : [Ôn thi ccna-step by step] Lab nat -- demo dùng để luyện cấu hình



tranmyphuc
30-04-2009, 03:03
Chào tất cả các bạn,
Tôi rất vui khi gởi đến các bạn demo bài LAB NAT . Một bài lab khá kinh điển và hầu như lúc nào cũng có thể ra trong kỳ thi CCNA quốc tế (640-801 hay 640-802).

http://networkselfstudy.com/forum/tailieu/NAT.swf

B1: Đầu tiên, chúng ta sẽ click vào Topology Information để xem mô hình mạng mà đề bài đã cung cấp cho chúng ta như thế nào :


http://vinaanh.com/images0/55940/f/49f6fb07e68fd_f.jpg

B2 : Sau khi đã xem mô hình mạng trên, để có thể hiểu được yêu cầu mà đề thi đã đưa ra chúng ta cần xem thông tại Scenario Information :


http://vinaanh.com/images0/55940/f/49f6fb0a15130_f.jpg



Việc xem thông tin ở 2 bước trên là một điều cực kỳ quan trọng vì khi ta hiểu yêu cầu đề bài thì mới có thể triển khai được trong bài LAB này. Do đây là Lab giả lập nên phần thông tin chỉ nêu ra những điều cốt lõi mà không nêu chi tiết như bài thi thật :

http://vinaanh.com/images0/55940/f/49f6fd5ad46de_f.jpg


Notes : Các bạn lưu ý rằng, :

+ Dãy địa chỉ IP trong bài LAB này sẽ thay đổi tùy theo đề thi .
+ Số lượng host trong đề bài cũng sẽ thay đổi

=> Buộc lòng các bạn phải nắm vững về VLSM và IP v4

B3: Sau khi đã xem kỹ 2 bước trên và hiểu được đề bài , chúng ta sẽ bắt đầu vào việc cấu hình bài LAB trên theo yêu cầu mà đề bài đã đưa ra :
Đối với demo này , chúng ta chỉ cần Click vào :
http://vinaanh.com/images0/55940/f/49f6fb0e40583_f.jpg

Sẽ vào được cấu hình , bao gồm 2 phần :
------B3 -1 : Nhắc lại yêu cầu đề bài ở bước 2 tại "Router Configuration"

http://vinaanh.com/images0/55940/f/49f6fb1089905_f.jpg

------B3 -2 :Mở ra màn hình Comand Line quen thuộc .
http://vinaanh.com/images0/55940/f/49f6fb14130cb_f.jpg

Notes : Đối với bài LAB thật thì , trong topo mạng chúng ta phải click vào PC có cổng console như hình dưới :

http://vinaanh.com/images0/55940/f/49f6fb1721ddf_f.jpg

Nó sẽ bung ra màn hình như sau mà không nhắc lại yêu cầu đề bài.

http://vinaanh.com/images0/55940/f/49f6fb14130cb_f.jpg

Muốn xem lại yêu cầu đề bài và mô hình mạng . Ta Click vào " Show Topology" tại :

http://vinaanh.com/images0/55940/f/49f7010bdcc11_f.jpg


B4 : Bây giờ chúng ta sẽ bắt đầu cấu hình : (yêu cầu tối thiểu phải hoàn thành bài LAB này trong vòng 10 phút)

Vì đây là giả lập LAB nên việc đánh đúng từng câu lệnh là điều mà người ta ra mong muốn . Do đó bạn đánh tắt ở đây sẽ không được :

http://vinaanh.com/images0/55940/f/49f6fb1fc7cb4_f.jpg

Vậy trong đề thi thật thì như thế nào ?

Notes :

+ Bạn có quyền dùng phím TAB để đánh được câu lệnh đầy đủ một cách dễ dàng.

+ Bạn cũng có thể dùng dấu "?" nếu quên . Tuy nhiên, hãy lưu ý điều này : rất ít bài LAB trong đề thi có hỗ trợ chức năng này !

+ Có thể dùng wr thay cho câu lệnh copy run start . Tuy nhiên , theo tôi bạn không nên dùng wr vì có một số bài LAB sẽ không hỗ trợ câu lệnh này.

+ Nếu như đề bài không cho bạn dùng bất cứ lệnh nào để lưu cấu hình, hãy bình tĩnh vì có thể nó đã mặc định dùng lệnh này rồi khi ta click NEXT để qua câu mới.

+ Vì là LAB giả lập nên sẽ có một số bài LAB không cho bạn dùng lệnh " No" để xóa câu lệnh đã cấu hình sai => bạn sẽ có khả năng sai bài LAB này. Chính vì thế, theo tôi hãy đánh chính xác từng câu lệnh.

+ Khi login vào cấu hình mode prividge , bạn phải thận trọng đánh đúng password đăng nhập vì nếu sai ba lần thì xem như bạn failed !!

Bài thứ 2 trong topic này sẽ đưa ra giải pháp tốt nhất cho bài LAB trên.

Chúc các bạn vui vẻ.


[=========> Bổ sung bài viết <=========]

Chào các bạn,
Trước khi giải quyết bài LAB trên, theo tôi các bạn cần xem thêm lý thuyết về NAT nếu như cảm thấy vẫn còn mập mờ về chứng năng này trên thiết bị Router của Cisco. Bài viết bên dưới sẽ giới thiệu ngắn gọn đến các bạn chức năng này.


NAT TRÊN THIẾT BỊ ROUTER



1. Giới thiệu

NAT (Network Address Translation) là một chức năng của Router, cho phép chuyển dịch từ một địa chỉ IP này thành một địa chỉ IP khác. Thông thường NAT được dùng để chuyển dịch từ địa chỉ IP private sang IP public, cho phép các host từ mạng bên trong truy cập đến mạng công cộng (internet). Vị trí thực hiện NAT là nơi (router) kết nối giữa hai mạng.



http://vinaanh.com/images0/55940/f/49f8a19fe82cd_f.jpg




Địa chỉ private và địa chỉ public


· Địa chỉ private
Được định nghĩa trong RFC 1918
10.0.0.0 – 10.255.255.255
172.16.0.0 – 172.31.255.255
192.168.0.0 – 192.168.255.255
· Địa chỉ public
Các địa chỉ còn lại. Các địa chỉ public là các địa chỉ được cung cấp bởi các tổ chức có thẩm quyền

2. Static NAT


Giới thiệu

Static NAT được thiết kế để ánh xạ một địa chỉ IP này sang một địa chỉ khác, thông thường là từ một địa chỉ nội bộ sang một địa chỉ công cộng và quá trình này được cài đặt thủ công, nghĩa là địa chỉ ánh xạ và địa chỉ được ánh xạ được chỉ định rõ ràng tương ứng duy nhất.
Static NAT rất hữu ích trong trường hợp những host cần phải có địa chỉ cố định để truy cập từ internet. Những host này có thể là những public server: mail server, web server,....



http://vinaanh.com/images0/55940/f/49f8a1a1a226a_f.jpg





Cấu hình static - NAT

Các lệnh được sử dụng trong cấu hình Static-NAT:
Router(config)#ip nat inside source static local_ip global_ip
Router(config-if)#ip nat inside
Router(config-if)#ip nat outside
Ý nghĩa các câu lệnh:
- Thiết lập mối quan hệ chuyển đổi giữa địa chỉ nội bộ bên trong và địa chỉ đại diện bên ngoài.
Router(config)#ip nat inside source static local-ip global-ip
- Xác định interface kết nối vào mạng bên trong
Router(config-if)#ip nat inside
- Xác định interface kết nối ra mạng công cộng bên ngoài
Router(config-fi)#ip nat outside
Ví dụ:

http://vinaanh.com/images0/55940/f/49f8a1a2a3da5_f.jpg






Cấu hình trên Router:
Router(config)#ip nat inside sourece static 10.1.1.2 172.69.68.10
Router(config)#interface Ethernet 0
Router(config-if)#ip nat inside
Router(config)#interface ****** 0
Router(config-if)#ip nat outside

2. Dynamic NAT


Giới thiệu

Dynamic NAT được thiết kế để ánh xạ một địa chỉ IP này sang một địa chỉ khác một cách tự động, thông thường là ánh xạ từ một địa chỉ private sang một địa chỉ public. Bất kỳ một địa chỉ IP nào nằm trong dải địa chỉ IP công cộng (public) đã được định trước đều có thể được gán cho một host bên trong mạng (private).

http://vinaanh.com/images0/55940/f/49f8a1a43451b_f.jpg



Cấu hình Dynamic NAT

- Các câu lệnh dùng trong dynamic NAT
Router(config)#ip nat pool name start_ip end_ip { netmask netmask | prefix-length prefix-length }
Router(config)#access-list access-list-number permit source [source-wildcard]
Router(config)#ip nat inside source list access-number pool pool-name
Ý nghĩa sử dụng của các câu lệnh như sau:
- Xác định dải địa chỉ đại diện bên ngoài (public): các địa chỉ NAT
Router(config)# ip nat pool name start-ip end-ip [netmask netmask/prefix-length prefix-length]
- Thiết lập ACL cho phép những địa chỉ nội bộ bên trong (private) nào được chuyển đổi : các địa chỉ được NAT
Router(config)# access-list access-list-number pertmit source [source-wildcard]
-Thiết lập mối quan hệ giữa địa chỉ nguồn đã được xác định trong ACL với dải địa chỉ đại diện ra bên ngoài
Router(config)# ip nat inside source list access-list-number pool name
- Xác định interface kết nối vào mạng nội bộ
Router(config-if)# ip nat inside
- Xác định interface kết nối ra bên ngoài
Router(config-if)#ip nat outside
Ví dụ:

http://vinaanh.com/images0/55940/f/49f8a1a649210_f.jpg



3. NAT Overload

http://vinaanh.com/images0/55940/f/49f8a1a7f0fcf_f.jpg



Giới thiệu

NAT Overload là một dạng của Dynamic NAT, nó thực hiện ánh xạ nhiều địa chỉ private thành một địa chỉ public (many – to – one) bằng cách sử dụng các chỉ số port khác nhau để phân biệt từng chuyển dịch. NAT Overload còn có tên gọi là PAT (Port Address Translation).

PAT sử dụng số port nguồn cùng với địa chỉ IP riêng bên trong để phân biệt khi chuyển đổi. Số port được mã hóa 16 bit, do đó có tới 65536 địa chỉ nội bộ có thể được chuyển đổi sang một địa chỉ công cộng.



http://vinaanh.com/images0/55940/f/49f8a1a9bcb5b_f.jpg




Cấu hình NAT Overload

- Dạng 1: Sử dụng chung một địa chỉ IP công cộng duy nhất.
Router(config)#access-list access-number permit source source-wildcard
Router(config)#ip nat inside source list access-list-number interface interface overload

- Dạng 2: ISP cung cấp nhiều địa chỉ IP công cộng
Xác định dãy địa chỉ bên trong cần chuyển dịch ra ngoài (private ip addresses range)
Router(config)# access-list access-list-number permit source source-wildcard

Xác định dãy địa chỉ sẽ đại diện ra bên ngoài (public ip addresses pool)
Router(config)# ip nat pool name start-ip end-ip [netmask netmask/prefix-length prefix-length]

Thiết lập chuyển dịch động từ các địa chỉ bên trong thành địa chỉ bên ngoài
Router(config)# ip nat inside source list acl-number pool name overload

Xác định interface inside và outside
Đối với interface inside: router(config-if)#ip nat inside
Đối với interface outside: router(config-if)#ip nat outside

Để có thể tìm hiểu kỹ hơn về NAT các bạn có thể vào : Lý thuyết NAT (http://networkselfstudy.com/forum/ccna/34-ly.thuy.t.nat.html)

[=========> Bổ sung bài viết <=========]

Question:

A network associate is configuring a router for the weaver company to provide internet access.
The ISP has provided the company six public IP addresses of 198.18.184.105 198.18.184.110. The company has 14 hosts that need to access the internet simultaneously. The hosts in the company LAN have been assigned private space addresses in the range of 192.168.100.17 – 192.168.100.30.
The following have already been configured on the router:
- The basic router configuration
- The appropriate interfaces have been configured for NAT inside and NAT outside
- The appropriate static routes have also been configured (since the company will be a stub network, no routing protocol will be required.)
- All passwords have been temporarily set to "cisco"

http://9tut.com/images/ccna/labsim/ccna_nat_sim_lab1.jpg
http://9tut.com/images/ccna/labsim/ccna_nat_sim_lab2.jpg

Solution:


Phần đọc hiểu đề bài , các bạn sẽ dễ dàng làm được( thời gian yêu cầu mất ít nhất 3 phút).

Dưới đây là giải pháp cho bài LAB trên :

== Công ty có 14 hosts cần phải truy cập internet cùng một lúc (simultaneously) nhưng chúng ta chỉ có 6 địa chỉ IP public từ 198.18.184.105 đến 198.18.184.110/29. Nhấp chuột trái 2 lần vào Weaver router để mở giao diện CLI. Lưu ý : Nếu như không có từ simultaneously thì chúng ta có thể cấu hình NAT dynamic và cả NAT Overload.


Router>enable
Router#configure terminal

Đầu tiên ta chuyển tên router thành Weaver

Router(config)#hostname Weaver

B1 : Tạo một NAT pool cho IP public..

Weaver(config)#ip nat pool mypool 198.18.184.105 198.18.184.110 netmask 255.255.255.248
B2: Tạo một ACLs cho phép những IP trong mạng nội bộ được phép ra internet.

Weaver(config)#access-list 1 permit 192.168.100.16 0.0.0.15
B3: Chúng ta tạo mối liên kết giữa B1 và B2 :


Weaver(config)#ip nat inside source list 1 pool mypool overload

Overload từ khóa cho phép nhiều IP mạng nội bộ được phép ánh xạ ra 1 ip public bằng cách dùng những port khác nhau . Nên NAT overload còn có tên gọi là PAT (Portable Address Translation)

B4 : Ta dựa vào mô hình mạng và tìm ra nơi thích hợp để apply NAT theo chiều vào và chiều ra.


Weaver(config)#interface fa0/0
Weaver(config-if)#ip nat inside
Weaver(config-if)#exit
Weaver(config)#interface s0/0
Weaver(config-if)#ip nat outside
Weaver(config-if)#end

B5 : Câu lệnh mà bất cứ bài LAB nào sau khi hoàn thành xong không được quên :


Weaver#copy running-config startup-config

Kiểm tra cấu hình của bạn bằng cách click vào "Host for testing" và đánh :
C:\>ping 192.0.2.114
!!!!!

Cảm ơn các bạn đã cùng tôi hoàn thành và hiểu thực sự bài LAB này.